Forum MicMac

This forum is dedicated the the community of MicMac users


All times are UTC + 1 hour



Post new topic Reply to topic  [ 2 posts ] 
Author Message
Offline

Joined: Mar 2020
Posts: 2
Gender: None specified
Posted: 22 Mar 2021, 21:24 

Hi all,
I am trying to install micmac again after too much time. I am working in kubuntu 20.10 and following the instructions from https://micmac.ensg.eu/index.php/Install_MicMac_Ubuntu

Phase 1.
Code:
sudo apt-get install git
sudo apt-get install make imagemagick libimage-exiftool-perl exiv2 proj-bin qt5-default cmake build-essential
git clone https://github.com/micmacIGN/micmac.git micmac


Phase 2 can be done in two ways
Way 1: automatic running script_jenkins_unix.sh -- It has not worked
Way 2: Manually
Code:
cd micmac/
mkdir build
cd build
cmake -DWITH_QT5=1 -DWITH_CPP11=1 ..
cmake ../
sudo apt-get install qt5-default qttools5-dev-tools
make install


In this last step I get an error I don't know how to deal with.

I can't upload the screeshot so her it goes the message when it has done 70% of the task
[ 70%] Building CXX object src/CMakeFiles/elise.dir/util/TD_Sol.cpp.o
[ 70%] Building CXX object src/CMakeFiles/elise.dir/util/cElCommand.cpp.o
[ 70%] Building CXX object src/CMakeFiles/elise.dir/util/visual_mainwindow.cpp.o
/home/usuario/micmac/src/util/visual_mainwindow.cpp: In member function ‘virtual void visual_MainWindow::resizeEvent(QResizeEvent*)’:
/home/usuario/micmac/src/util/visual_mainwindow.cpp:991:71: error: ‘int QDesktopWidget::screenNumber(const QPoint&) const’ is deprecated: Use QGuiApplication::screenAt() [-Werror=deprecated-declarations]
 991 |     QRect desk_rect = m->screenGeometry(m->screenNumber(QCursor::pos()));
     |                                                                       ^
In file included from /home/usuario/micmac/src/saisieQT/include_QT/Elise_QT.h:40,
                from /home/usuario/micmac/src/saisieQT/include_QT/saisieQT_window.h:4,
                from /home/usuario/micmac/include/general/visual_mainwindow.h:9,
                from /home/usuario/micmac/src/util/visual_mainwindow.cpp:3:
/usr/include/x86_64-linux-gnu/qt5/QtWidgets/qdesktopwidget.h:75:60: note: declared here
  75 |     QT_DEPRECATED_X("Use QGuiApplication::screenAt()") int screenNumber(const QPoint &) const;
     |                                                            ^~~~~~~~~~~~
/home/usuario/micmac/src/util/visual_mainwindow.cpp:991:72: error: ‘const QRect QDesktopWidget::screenGeometry(int) const’ is deprecated: Use QGuiApplication::screens() [-Werror=deprecated-declarations]
 991 |     QRect desk_rect = m->screenGeometry(m->screenNumber(QCursor::pos()));
     |                                                                        ^
In file included from /home/usuario/micmac/src/saisieQT/include_QT/Elise_QT.h:40,
                from /home/usuario/micmac/src/saisieQT/include_QT/saisieQT_window.h:4,
                from /home/usuario/micmac/include/general/visual_mainwindow.h:9,
                from /home/usuario/micmac/src/util/visual_mainwindow.cpp:3:
/usr/include/x86_64-linux-gnu/qt5/QtWidgets/qdesktopwidget.h:79:67: note: declared here
  79 |     QT_DEPRECATED_X("Use QGuiApplication::screens()") const QRect screenGeometry(int screen = -1) const;
     |                                                                   ^~~~~~~~~~~~~~
cc1plus: all warnings being treated as errors
make[2]: *** [src/CMakeFiles/elise.dir/build.make:10216: src/CMakeFiles/elise.dir/util/visual_mainwindow.cpp.o] Error 1
make[2]: Leaving directory '/home/usuario/micmac/build'
make[1]: *** [CMakeFiles/Makefile2:439: src/CMakeFiles/elise.dir/all] Error 2
make[1]: Leaving directory '/home/usuario/micmac/build'
make: *** [Makefile:130: all] Error 2


Any help will be more than welcome. Is it expected micmac to be part of official repositories?
Kind regards
Jaime


Top
  Profile 
 
Offline

Joined: Jul 2011
Posts: 1050
Gender: Male
Age: 31
Posted: 30 Mar 2021, 14:20 

Hmmm, It looks to me taht the QT part of the MicMac code has some deprecated (old) functions that your (I would guess) very recent install of QT can't work with anymore. I do not think any QT update will be done for micmac in the near future, so the only way would be to downgrade QT to an older version (5.10 worked, for instance, IIRC). It might also be something completely different, but that's what the errors hint at to me.

_________________
Join the MicMac community on Reddit : /r/MicMac/
Don't forget to check the wiki : http://micmac.ensg.eu


Top
  Profile 
 

Who is online

Users browsing this forum: No registered users and 0 guests

Permissions of this forum:

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
Post new topic Reply to topic  [ 2 posts ] 


Créer un forum | © phpBB | Entraide & support | Forum gratuit